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INTRODUCTION
Tag Meta is a Joomla! 1.5 native extension that allows you to efficiently manage site meta tags. Tag Meta
allows to set the tag 'title' and the meta tags 'description', ‘author’, 'keywords' and 'robots' on each page,
which is identified by the URI or a part of it. Also the rel ‘canonical’ is supported, and there’s a customizable
database of synonyms for each keyword. This provides a powerful tool to improve site positioning in SEO
optimization.
It was created because many Joomla extensions don’t provide a way to set meta info on their pages, and in
these cases Tag Meta helps you to do this. So, first thing you should understand is to use Tag Meta only
when there are no other ways or for some advanced “things”. For an article, as example, you can provide
simple “Metadata Information” inside the article edit screen, so probably in this case you don’t need to use
Tag Meta. But if you create a menu item that points to a component, you can’t set metadata into menu edit
screen, so if the component doesn’t provide you a way to do this, you can use Tag Meta.
For best SEO results, remember to use meaningful descriptions for title and description, concerning the
content of the pages, and also remember to insert comma separated keywords (with no spaces).
Finally, it is recommended to use native Joomla! SEO options (“Site” -> “Global Configuration” -> “Site”,
look at “SEO Settings” box), to simplify the structure of the site URLs, improving both page positioning, and
meta info management to associate to each URI.

HOW IT WORKS
Tag Meta consists of a component for managing URI list, and a plugin that is in charge of setting the meta
info on the page. These are the main steps to make it work (for geeks):
1. Install the package using Joomla! Administration interface;
2. Activate the plugin “System - Tag Meta” and set its position and global parameters;
3. Use Tag Meta component's functions to manage meta info and synonyms.
Detailed instructions on each step are described in the following paragraphs. In this section we just want to
focus on some basic concepts related to Tag Meta and how it works.
The first important thing to understand is the “item” concept. With Tag Meta Manager (the component
interface) you can create as many “item” as you want, and each item has its meta info. But not necessarily
an item corresponds to a single page (i.e. matches just a single URL).
An item has a “URI” field that can be full URI or just a part of it. For example, if the configured “URI” field
for an item is “/home.html”, then this item matches both the URL http://www.mysite.com/home.html
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and http://www.mysite.com/orders/home.html?view=status. So, it means that with a single item is
possible to match multiple site URLs.
When an user requests a site URL, the plugin take the “path+query” parts of the URL1 and compares this
string with the list of (published) item’s “URI”, considered in their order set. The first matching item found
(if there’s at least one) is used to set page meta info.
Last thing to understand about the item is that the “URI” field can be a regular expression. These provide a
powerful way to specify complex search patterns for matching URL. In the next paragraphs will be shown
many regular expression examples.

INSTALLATION PROCEDURE
Since version 1.3 of Tag Meta there is just one package to download and install. This package includes both
the needed component and plugin, and supports the installation with “upgrade” mode, so there’s no need
any more to uninstall any previous version of Tag Meta.
To install Tag Meta, login to Joomla! backend as administrator, and go to menu “Extensions” ->
”Install/Uninstall”.
Click the browse button, select the package file (TagMetaX.XCommunity.zip or tagMetaJX.XEnterprise.zip)
and click the install button.

That’s all. Now we are ready to start using Tag Meta.

1

NOTE: The URL’s parts “scheme”, “user”, “pass”, “host” and “port” are dropped, so the domain name must not be
included in the item’s URI field.
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UPGRADE PROCEDURE
If you are upgrading from a previous version of Tag Meta,there is no need to first uninstall old component
and plugin. As mentioned earlier, since version 1.3 of Tag Meta the “upgrade” mode is supported for the
installation, so just install the new package over the old one, both component and plugin will be upgraded.
Note that when upgrading Tag Meta also the database tables are upgraded without to delete any table
data, so your items will be preserved. It is in charge of the installation process to upgrade tables
structure as needed.

USAGE
Remember that is the plugin that “do the work”. Tag Meta component is just an administrative interface
that let you manage your items, but is the plugin that check site calls and override the meta info when
needed. So, first thing is to enable the plugin. Note that if you need to disable Tag Meta, just disable the
plugin.
Go to menu “Extensions” -> “Plugin Manager”, find “System - Tag Meta” in the list and click on it to enter
into configuration page.

Set “Enabled” to “Yes”, and set other parameters on the right side according to your needs. Look at “Plugin
settings” paragraph for detailed information of each parameter.
Click on “Save” and check that plugin is enabled.
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Last thing to check is the plugins order, that can be much important especially if there are some other
plugins that mess with meta information. Normally, it should be better to put Tag Meta as the last system
type plugin in the list, so it will be the last to set page meta info.
Now Tag Meta is ready to work! Let’s create our first item, and after this let’s test the meta information
from the web browser to verify that Tag Meta is working. Note that you could get a cached page with old
meta tag values. To avoid this, remember to clear server-side cache from Joomla! Backend (menu “Tools”
-> “Clean Cache”, “Site” tab, select all and click “Delete” button), and client-side cache from your web
browser.
To add an item go to menu “Components” -> “Tag Meta” –> “Items”, to access to Tag Meta Manager.

From here, to add new item click on “New” button. It will be shown a screen for entering information
related to an item.
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The “URI” field must contains an “URL part” to compare with browser URL. Remember that “URI” must not
contains URL’s parts “scheme”, “user”, “pass”, “host” and “port”.
The field “Case sensitive” specify if the match between item and current URL must consider the letters case
(i.e. uppercase and lowercase are considered different). So, in case sensitive mode the item must match
with current URL also for the case of characters. If case sensitive is off, no matter if item or current URL
differs only for case of characters (i.e. MyPage.php = myPage.PHP = mypage.php).

7

www.sistemistica.it

Tag Meta – Quick Guide Rev. 2

Fields “Published” and “Order” have the usual Joomla! meaning. Other fields “Title”, “Description”,
“Author”, and ”Keywords” are related to common meta information for URLs that match with current
item. There are also robots information available on the right side of the same page.

The field “Canonical” allow to set the rel “canonical” meta information on the matching URLs. More
information on how to use the rel “canonical” meta tag in efficient manner are available here:
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=139394
The “Comment” field is just an annotation that can be attached to the item, and is not used in any way on
the matching URLs.
Fields “Use Synonyms”, “Max Synonyms”, and “Use Synonyms Weight” are related to the Keywords
Synonyms database feature, and their meaning will be explained in the Synonyms Database section.
Finally, the field “Hits” counts the number of times this item were used, while the field “Last visit” indicates
the last time this item were used. Here you can change the counter value if needed.
In our example the URI field contains:
/download.html
We must talk in the plural when we said “URLs that match with this item” because the URI specified in a
single item can match more than a single browser URL. In the previous example, with “/download.html”
we match ANY URL in the form:
http://www.mysite.com/download.html
http://www.mysite.com/download.html?itemid=xxx
…
http://www.mysite.com/directory/download.html?id=xxx
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This behavior makes Tag Meta very flexible, but that’s not all.
It is also possible to use Regular Expressions into URI field. Tag Meta, in fact, supports regular expressions
according to Henry Spencer's implementation:
http://dev.mysql.com/doc/refman/5.0/en/regexp.html
And this feature makes it extremely powerful when you can master it.
The following table shows some examples. Look at “Examples and Solutions to common problems”
paragraph for more advanced examples.

URI field

What does it mean

/section/*$

The dollar ($) means “end with”. The star (*) means “match
zero or more occurrences of previous character”, that is the
slash (/). So, the URI field means “address ends with /section or
/section/”.

^/section/9-article.html$

The hyphen (^) means “start with”. The dollar ($) means “end
with”. So, the URI field means “address starts and ends exactly
with /section/9-article.html”.

^/section/11-articles.php\?id=12$

The hyphen (^) means “start with”. The dollar ($) means “end
with”. Also, we need a “literal” question-mark (?) for inline
arguments, so it must be escaped with a backslash (\?). So, the
URI field means “address starts and ends exactly with
/section/11-articles.php?id=12”.

Last thing to know about the URI field matching address is that even the items order is important. For
each URL request, Tag Meta searches all the matching (published) items, but ONLY THE FIRST ONE in the
ordering set is used. This can be useful, as example, to distinguish a category from its articles. If we have
two URLs as follow:
http://www.mysite.com/category/
http://www.mysite.com/category/article-1.html
Items could be configured with the following URI field:
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Wrong Order

Correct Order

/category/

/category/article-1.html

/category/article-1.html

/category/

For the browser URL http://www.mysite.com/category/article-1.html, if items are set in the wrong order,
both items match the URL, but remember that only the first matching item (/category/) is applied, so the
meta info for page article-1.html will never be used.

LIST OF SUPPORTED MACROS
Tag Meta supports use of “macros” that allow to generate dynamic content (i.e. content generated at runtime and based on the current page state). These macros can be used into these item fields:





Title;
Description;
Author;
Keywords.

So, anytime a supported macro is found in one of the fields above, Tag Meta replaces it with the current
value. Here is a list of supported macros for these fields:
Macro
{siteurl}
{sitename}
{globaldescription}
{globalkeywords}
{currenttitle}
{currentdescription}
{currentkeywords}
{currentauthor}
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Example
Web site address (e.g.
www.example.com/path/to/Joomla)
Web site name (from Joomla configuration)
Global site meta description (from Joomla
configuration)
Global site meta keywords (from Joomla
configuration)
Current page title, (as found by Tag Meta
before to start to modify page meta info)
Current page meta description (as found by
Tag Meta before to start to modify page meta
info)
Current page meta keywords (as found by Tag
Meta before to start to modify page meta
info)
Current page meta author (as found by Tag
Meta before to start to modify page meta
info)

www.sistemistica.it

Tag Meta – Quick Guide Rev. 2

{currentgenerator}

{autokeywords M,N}

{autokeywords2 M,N}

Current page meta generator (as found by Tag
Meta before to start to modify page meta
info)
Automatic single-word keywords generation (M
is minimun length of admitted words, N is
number of comma separated keywords to return)
- ENTERPRISE VERSION ONLY
Automatic double-word keywords generation (M
is minimun length of admitted words, N is
number of comma separated keywords to return)
- ENTERPRISE VERSION ONLY

Macros highlighted are only available for Enterprise version of Tag Meta.
NOTE: The macro substitution happens before to check for synonyms, so if macros are included into the
“keywords” field, first these macros are expanded and then the synonyms are checked.

SYNONYMS DATABASE
Synonyms section allows the creation of an ontology of keywords with similar meaning. This database can
be used to automatically associate to site pages keywords with similar meaning, or similar to each other.
To manage the synonyms database go to menu “Components” -> “Tag Meta” –> “Synonyms”.

To add new synonyms item click on “New” button. It will be shown a screen for entering information
related to an item.
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Usage is really simple:





The Keywords field must contain a list of similar words, separated by commas (e.g.
joomla,Joomla,cms,open source);
The Synonyms field, similarly, must contain a list of synonyms to be used in addition to any of the
previous keywords (e.g. joomla,Joomla,cms,open source,OSM,Open Source Matters). Typically (but
not necessarily) the two lists of words match. But in some cases a word can be included only from
the keywords, or from the synonyms. In our example, “tag meta”and “redj” words are included
only in the synonyms list, so we want to consider these as synonyms for “seo”, “sef”, and so on, but
the opposite is not true.
The Weight field can be used to specify a preference between items. If a keyword is present in the
Keywords field of multiple rows, then all these rows will be used to extract synonyms. With option
“Use Synonyms Weight” of a Tag Meta item, these rows will be sorted by weight, so we can decide
the synonyms importance through the weight.

Once created the synonyms database, to use it there are three fields available in any Tag Meta item.
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These fields are:
Use Synonyms
When set to “No” the synonyms database will be ignored when the current item will be used. To activate
the synonyms feature set this option to “Yes” or to “Yes (case sensitive)”. The latter (case sensitive) means
that the letter case must be considered when searching for a keyword into the “Keywords“ field of
synonyms database (when case sensitive is enabled the keyword “Joomla” is considered different from
“joomla” and they don’t match each other).
Max Synonyms
It’s the total maximum number of synonyms that will be added to the keywords that already exist, going to
search through all the synonyms of all the keywords present initially. Note that the number of synonyms
that will be added may be less then specified, if there are not enough synonyms in the database for the
initial keywords.
Use Synonyms Weight
This option specifies whether to use or not the value of the field “Weight” of each synonyms item for the
ordering of the synonyms items. As mentioned earlier, the weight represents a way to specify the
importance of keywords, and the order in which we prefer they are used.

PLUGIN SETTINGS
In this paragraph we will explain the meaning of each plugin parameter. To edit plugin settings go to menu
“Extensions” -> “Plugin Manager”, find “System – Tag Meta” in the list and click on it to enter into
configuration page.
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Basic Plugin Parameters

In the following table there’s a list of all basic plugin parameters.
Name

Value

Description

Custom Meta Author

Text

Custom value for meta tag 'author.

Add Meta Author

No/Yes/Preserve

No, disabled. Yes, always add custom meta tag
'author' (replace if already exists). Preserve, add
custom meta tag 'author' only if this is not present.

Custom Meta Generator

Text

Custom value for meta tag 'generator'.
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Replace Meta Generator

No/Yes/Clean

No, disabled. Yes, on any page replace value for meta
tag 'generator' if this is present with the custom one.
Clean, on any page unset value for meta tag
'generator' if this is present.

Add site name to page
title

No/Before/After

Position of site name related to pre-existent page title.
No, disabled.
String to use as separator. Use <strong>\b</strong>
for a blank space.

Separator string

No/Yes

Force the default page (home) to have only site name
in page title.

Align Meta Title

No/Yes/Force

No, disabled. Yes, on any page sync meta tag 'title'
with tag 'title' when both present. Force, on any page
sync meta tag 'title' with tag 'title' when at least one is
present, favoring the tag 'title' when possible.

Mode REDIRECT

No/Yes

Use REDIRECT_URL instead of REQUEST_URI when
defined. Useful, for example, to work with friendly
URL rewrited by sh404SEF.

Clean default page

Advanced Plugin Parameters
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In the following table there’s a list of all advanced plugin parameters.
Name
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Use early redirect

Base path

No/Yes

Check for redirect in a early phase. Useful only for
Internal Redirect (Enterprise version), to prevent
conflict with other extensions (e.g. Joomfish)

Text

The Joomla base installation path (e.g. /myportal if the
site's homepage is http://www.mysite.com/myportal).
This string will be dropped from the current URI, so to
increase portability for configured items. Leave blank
if the site is installed on the root.

EXAMPLES AND SOLUTIONS TO COMMON PROBLEMS
These are some of the common questions posted on support forum.
How to

Solution

Match only site homepage:

Create an item with the following URI field:

http://www.mysite.com/

^/$
The expression means “start and end with slash (/)” (i.e.
there’s ONLY the slash).

Match an URL with one or more parameters:

Create an item with the following URI field:

http://www.mysite.com/catalog.php?page=1&order
=asc

/catalog.php\?page=1&order=asc
or
/catalog.php[[.question-mark.]]page=1&order=asc
In both cases you need to “escape” the question mark (?). You
can do it with a backslash (\) behind, or replacing with string
“[[.question-mark.]]”.

Match all the URLs in the following form:

Create an item with the following URI field:

/index2.php?option=com_content&task=view&id=1
59&pop=1&page=52&Itemid=10218

/index2.php\?option=com_content&task=view&id=[09]{1,3}&pop=1&page=[0-9]{1,2}&Itemid=[0-9]{1,5}
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/index2.php?option=com_content&task=view&id=1
7&pop=1&page=0&Itemid=72
/index2.php?option=com_content&task=view&id=3
01&pop=1&page=0&Itemid=10440
/index2.php?option=com_content&task=view&id=7
7&pop=1&page=0&Itemid=113
…

The expression [0-9]{1,5} means “a sequence from 1 to 5
digits”.

GET SUPPORT
If you need help with Tag Meta, post a request on support forum:
http://www.sistemistica.it/forum.html
To send us private data like access credentials to your backend, use the contact email:
info@sistemistica.it

SUPPORT US
If you like this extension and found it useful, would you consider a small donation to support both site and
development. It's easy... just go to menu “Components” -> “Tag Meta”, select the “About” tab, and click on
Paypal image button, or use the link below:

https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=9YA4PNLYMLDHC
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